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Summary of Findings

The software described herein is built around free components, namely Tcl/Tk, a string-based scripting lan-
guage with widgets for developing graphical user interfaces (GUIs), and OpenSees, an open source nonlineal
finite element analysis software framework. This combination of Tcl/Tk and OpenSees allowed for rapic
prototyping of GUIs that interact with state-of-the-art element and constitutive models for the analysis o
cast-in-steel shell (CISS) bents. From a computational point-of-view, very little “from-scratch” coding was
required as modules available in OpenSees were repackaged to meet AKDOT&PF's needs. This development
approach will be fruitful for future AKDOT&PF software projects and potentially for commercialization anc
technology transfer. Based on collaboration and feedback from Mr. Elmer Marx, the software was found tc
be generally easy to use for analyzing a wide range of CISS bents in the AKDOT&PF inventory and more
efficient compared to the variety of separate software previously used for such analyses.



Software Limitations and Release of
Liability

The Alaska DOT&PF Pile Extension Pier Pushover Software is a powerful tool that includes geometric and
material nonlinearities, both structural material and soil, in determining the lateral load-deflection response
of bridge piers. The results of any analysis are sensitive to the input parameters. The engineer must be
fully aware of the assumptions and limitations described in this document, as well as those that are part o
the greater body of engineering knowledge, when using the software. As with all engineering software, the
results should be verified by a professionally licensed engineer.

The user agrees to indemnify and hold the States of Alaska and Oregon harmless from any claim or
demand, including attorneys’ fees, made by any third party as a result of using the software.



Chapter 1

Getting Started

The zCISS software is developed using the Tcl/Tk scripting language for model generation and graphical user
interfaces in conjunction with OpenSees as its computational engine for nonlinear finite element analysis. The
combined use of OpenSees and Tcl/Tk makes zCISS platform-independent, with only aesthetic differences
in the GUI. The installation and startup instructions described in this chapter are based on the Windows
operating system.

1.1 Installation Instructions
The user is required to install Tcl/Tk (64-bit) version 8.6 or later, which is available free of charge at
http://www.activestate.com/activetcl

In addition, the user must have the Tk-version (64-bit) of OpenSees (OpenSeesTk.exe) installed, which can
also be downloaded for free at

http://opensees.berkeley.edu

1.2 Startup Instructions

With OpenSeesTk.exe and zCISS.tcl installed in the same directory, there are two options to start the
software under the Windows operating system.

1. Double-click on the OpenSeesTk.exe icon. An MS-DOS window will then appear showing OpenSees
copyright information along with an interactive prompt. In addition, there will be a plain grey window
titted openSeesTk, as shown in Figure 1.1. At the prompt in the MS-DOS window, type source
zCISS.tcl (also shown in the figure). This will cause the plain grey window to change to the
zCISS startup window shown in Figure 1.3.


http://www.activestate.com/activetcl
http://opensees.berkeley.edu/

2. Drag the zCISS.tcl icon over the OpenSeesTk.exe icon, as shown in Figure 1.2 and release. The
zCISS startup window shown in Figure 1.3 should appear immediately along with the MS-DOS window
showing OpenSees copyright information.

mhscott) DpensSeesCYSs', Win324bin',openSeesTk.exe

Open%ees — Open System For Earthguake Engineering Simulation
Pacific Earthguake Engineering HResearch Center — 2.1.1

{c) Copyright 1999 The Regents of the University of California
All Rights Reserved

CCopyright statement @ http:/  uwu_berkeley.edusOpenSeesscopyright html)>

OpenSees > source zCISS.tcl_

Figure 1.1: MS-DOS window created by double-clicking on the OpenSeesTk.exe icon.

1.3 Default Bent Model

Upon startup, the software creates a default bent model with the basic details shown in Figure 1.3:

Three 36.0 in diameter column/pile extensions where column and pile sections have the same geometry
and reinforcing detalils;

Column/pile extensions 8.0 ft on center, each with 984.4 kip axial load and 2.0 in gap at bent cap;

Columns 14.0 ft above grade extending 60.0 ft below grade;

Three 20.0 ft sand layers with water table at 3.0 ft; and

All p-multipliers are equal to 1.0.

Further reinforcing details, soil properties, and analysis options for this default model are omitted from this
list for brevity. The default values for the structural components and soil layers are shown in Chapter 2
The number of columns and soil layers, along with the above and below grade heights of the column/pile
extensions can be changed by modifying the input fields on the startup screen.

In addition to the basic bent properties, names for the bridge and engineer can be changed from their de-
fault values (bridge name BridgeXYZ, where XYZ is a system-dependent number obtained from the Tcl [clock

10
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Figure 1.2: Dragging the zCISS.tcl icon over the OpenSeesTk.exe icon in Windows Explorer.

clicks] command, and engineer name John Doe, P.E.). These names will be echoed in the analysis report
generated by the software.

Buttons are available on the main window for performing three types of analysis on the bridge bent;
Transverse Pushover, Longitudinal Pushover, and Dynamic Analysis. Further details on these analyses
are described in Chapter 3. There s also the Draw Bent button to draw the bridge bent after making changes
to the model and the Create Report button to generate an analysis report for the bridge bent with contents
described in Chapter 4.

11



Alaska DOT&PF Pile Extension Pier Pushover Program, v2.0
File Edit Help |

Bridge|Bridge1482749380279606
Engineer |John Doe, P.E.

Number of Columns |3 Number of Soil Layers |3
Above Grade Height (ft) 14.0  Below Grade Depth (ft) |60.0

Draw Bent ‘ Transverse Pushover ‘ Longitudinal Pushover ‘ Dynamic Analysis Create Report ||

984.4 984.4 984.4
kip kip kip

Figure 1.3: Main window created after software is started.
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Chapter 2

Bent Inputs

Inputs for the column/pile extensions, bentcap, and soil are described in this chapter along with details on
saving the bent modelto a file and loading previously saved models.

2.1 Column Section

The geometry and reinforcing details are assumed to be the same for each column in the bridge bent. Use
one of the following two methods to view and edit the column cross-section:

< Double-click on a column in the main window (Figure 1.3); or
e Select Edit -> Section -> Column from the main menu.

After using one of these methods to access the column cross-section, the user interface shown in Figure 2.1
appears. Properties for the Steel Shell, Longitudinal Reinforcement, and Transverse Reinforcement
can be modified through this interface.

Steel Shell

« Diameter — outer diameter of the steel shell

Units: in, Default: 36.0 in

* Thickness — thickness of the steel shell
Units: in, Default: 0.75 in

Note: set this value to zero in order to remove the steel shell

Longitudinal Reinforcement

« Clear Cover — distance from outer face of spiral transverse reinforcement to inside of steel shell

Units: in, Default: 2.0

13



% Column Section

File Materials Analysis Help

Steel Shell Longitudinal R/F Transverse RIF
Diameterlﬂ&.[] in Clear Cover 2.0 in Spacing 3.0 in
'I11ickn955|[].?5 in  Number of Bars |16 Yield Stress 60.0  ksi
Bar Size 11 — Bar Size 5 —

Ok | Cancel |

Figure 2.1: Userinterface for column cross-section geometry and reinforcing detalils.



« Number of Bars — number of longitudinal reinforcing steel bars placed evenly around section

Default: 16

Note: set this value to zero in order to remove longitudinal reinforcement

e Bar Size — US size for the longitudinal reinforcing steel bars
Default: 11, Range: 3-18
Transverse Reinforcement

e Spacing — center-to-center vertical spacing, or pitch, of the transverse spiral reinforcement

Units: in, Default: 3.0

e Yield Stress - yield stress of the transverse reinforcing steel

Units: ksi, Default: 60

e Bar Size — US size for the transverse reinforcing steel bars
Default: 5, Range: 3-18
The material properties of the concrete, reinforcing steel, and steel shell of the column cross-section can be

modified through additional interfaces, as described in the following sections.

2.1.1 Concrete Properties

The concrete in all columns/piles is assumed to have the same nominal strength; however, the confining
effects of spiral reinforcement and the steel shell are taken in to account automatically by the software. To
modify the concrete properties, use one of the following methods:

< Double-click anywhere in the concrete area of the column section window (Figure 2.1); or
e Select Materials -> Concrete from the column section menu.

After using one of these two methods to access the concrete properties, the user interface shown in Figure 2.2
appears and the following properties can be modified through this interface:

= f_ce — expected 28-day compressive strength of unconfined concrete

Units: ksi, Default: 5.2

e e_co - strain at which 28-day compressive strength is reached

Units: in/in, Default: 0.002

e e_sp — strain at which concrete is completely spalled in compression

Unists: in/in, Default: 0.006

15



Concrete Properties

File Help

Unconfined: f ce 5.2 ksi

e co(0.002 infin
e sp (0.006 infin
CI55 Section: f cc| @ 220 ksi
e cc[0.0197 infin
Gap Section: f cc[7 =970 ksi
e cc[0.00G¢ infin
Pile Section: f cc| © ¢ ksi
e cc[0.0197 infin
Stress-Strain
OK | Cancel |

Figure 2.2: Userinterface for concrete properties.
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Using the unconfined concrete properties, the software computes automatically the compressive strength,

fcc, and corresponding strain, ecc, for the gap section, steel shell column section, and steel shell pile section
Concrete confinement in the gap section is based on the model proposed by Mander [4] while confinement
for the column and pile sections wrapped in a steel shell is based on the model proposed by Chai et al [1]
The confined concrete properties based on these models is shown in Figure 2.2 for the default values o
unconfined concrete strength. The unconfined concrete behavior is based on the model proposed by Kent e
al [3]. There is also a button, Stress-Strain, to generate and view the stress-strain curves for each concrete
model. This information is also echoed in the report generated by the software, as described in Chapter 4
and will not be described here.

2.1.2 Steel Properties

Similar to the concrete, the steel properties are assumed to be the same in all columns/piles of the bridge
bent model; however, the longitudinal reinforcing steel and steel shell may have different properties. To
modify the reinforcing steel properties, use one of the following methods:

< Double-click on one of the reinforcing bars in the column section window (Figure 2.1); or
« Select Materials -> Reinforcing Steel from the column section menu.

After using one of these two methods to access the reinforcing steel properties, the user interface showr
in Figure 2.3a appears. The steel stress-strain response is based on the model proposed by Raynor [8], foi
which the following properties can be modified:

e E —elastic modulus

Units: ksi, Default: 29,00C

= f_ye — expected initial yield strength
Units: ksi, Default: 68.0

= f_ue — expected ultimate strength

Units: ksi, Default: 95.0

e e_sh —strain at the onset of strain hardening

Units: in/in, Default: 0.011E

e e_suR —reduced ultimate strain

Units: in/in, Default: 0.06

e e_su — ultimate strain

Units: in/in, Default: 0.09

17



* Cl — power curve parameter

Default: 1.5

£ Steel Shell Properties

= File Help
Reinforcing Steel Properties -
E|29000.0 ksi

e HeE | f ye 60.0 ksi
E|29000.0 ksi :
f ye|68.0 " fue 78.0 ksi

f ue(95.0 ksi e sh(0.0115 infin

e sh|(0.0115 infin e suR |D-Dal infin

e suR|0.06 infin e su |D-Dl5 infin
e su|0.09 infin _Cl Il'_:ri
Cl[1.5 :

Stress-5train | Stress-Strain |
OK | Cancel | OK | Cancel |
(a) Reinforcing steel. (b) Steel shell.

Figure 2.3: Userinterfaces for longitudinal reinforcing steel and steel shell properties.

There is also a button, Stress-Strain, to generate and view the stress-strain curves for the reinforcing
steel. This information is also echoed in the report generated by the software, as described in Chapter 4,
and will not be described here.

The stress-strain behavior of the steel shell follows the same Raynor model as that used for the reinforcing
steel; however, the default values differ, as shownin Figure 2.3b. To modify the steelshell properties, use
one of the following methods:

< Double-click on the steel shellin the column section window (Figure 2.1); or
e Select Materials -> Steel Shell from the column section menu.

After using one of these two methods to access the reinforcing steel properties, the user interface shown in
Figure 2.3b appears.

2.2 Pile Section

Like the columns, the geometry and reinforcing details are assumed to be the same for each pile in the bridge
bent. Use one of the two following methods to view and edit the pile cross-section:

18



« Double-click on a pile in the main window (Figure 1.3); or
» Select Edit -> Section -> Pile from the main menu.

After using one of these methods to access the pile cross-section, the user interface shown in Figure 2.4
appears. By default, the software assumes the pile section has the same geometry and reinforcing details
as the column cross-section. As a result, the input fields are disabled, as shown in Figure 2.4a. These
input fields are enabled by de-selecting the Make pile section same as column checkbox, as shown ir
Figure 2.4b. All input properties for the section geometry and reinforcing details, as well as the concrete anc
steel material properties, have the same meaning as those for the column section described in Section 2.1
and are not repeated here.

Pile Section Pile Section

File Materials Analysis Help | File Materials Analysis Help
Steel Shell Longitudinal R/IF Transverse R/F Steel Shell Longitudinal R/IF Transverse R/F
Diameter[-5. 0 in Clear Cover[> 0 in Spacing[> 0 in Diameter 36.0 in Clear Cover 2.0 in Spacing 3.0 in
Thickness|[0 7= in Numberof Bars[ & Yield Stress|- 0 0 ksi Thickness[0.75 in Number of Bars|16 Yield Stress |60.0  ksi
Bar Size — Bar Size — Bar Size 11 — Bar Size 5 —
Change at depth l— ft Change at depth 5.0 ft
= [~ No concrete in pile
W Make pile section same as column [~ Make pile section same as column

Cancel Cancel

(a) Pile same as Column (Default). (b) Pile different from Column.

Figure 2.4: User interface for pile cross-section geometry and reinforcing details.

Two additional values are available for editing via the pile cross-section interface:

e Change at depth — subgrade depth where the column section changes to the pile section

Units: ft, Default: 5.0

19



* No concretein pile — option to remove concrete and reinforcing steel, making the pile section a
hollow steel shell

Default: False

2.3 Gap Region

The length of the gap between the steel shell at the column to bent cap connection, along with the plastic
hinge length and concrete confinement in the gap region can be accessed and edited using one of the following
methods:

< Double-click on the Gf=XX in text in the main window (Figure 1.3); or
e Select Edit -> Gap Region from the main menu.

After using one of these methods to access the properties of the gap region, the user interface shown in
Figure 2.5 appears and the following properties can be modified therein:
e Gap, Gf — The length of the gap between the column steel shell and the bent cap
Units: in, Default = 2.00
e Plastic Hinge Length, Ip — The plastic hinge length over which damage is expected from the gap
regionin to the column member.

Units: ft, Default: 2.50

Although the user can specify any length, the plastic hinge length is computed automatically, when
the gap length is changed, according to the following relationship:

|p =Gf + 0.3fydt (2.1)

where Gr is the gap length, fy is the yield stress of the longitudinal reinforcing steel, and d;, is the
diameter of the longitudinal reinforcing steel bars.

e Core Confinement —confining behavior assumed for the core concrete of the gap region, either with the
steel shell and transverse reinforcement (Steel Shell), or only the transverse reinforcement (Spiral
Hoop)

Default: Spiral Hoop

Cover Confinement — confining behavior assumed for the cover concrete of the gap region, either the
same as that assumed for the core concrete (Same as Core), or no confinement (Unconfined)

Default: Same as Core
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File Help |

Gap. Gf 2.0 in
Plastic Hinge Length, Ip 2.50 ft
Core Confinement  Steel Shell © Spiral Hoop

Cover Confinement ~+ Same as Core ¢ Unconfined

oK | Cancel |

Figure 2.5: Userinterface for plastic hinge length and confinement of gap region.

2.4 Bent Cap

The dimensions of the bent cap can be accessed and edited using one of the following methods:
e Double-click on the bent cap in the main window (Figure 1.3); or
e Select Edit -> Bent Cap from the main menu.

After using one of these two methods, the user interface shown in Figure 2.6 appears and the following bent
cap properties can be modified:
< Depth — vertical, in-plane dimension of the bent cap

Units: in, Default: 48.0

« Width — out-of-plane dimension of the bent cap

Units: in, Default: 72.0

< Left Overhang — overhang length on the left side of the bent cap, measured from the exterior face of
the trailing column

Units: in, Default: 24.0

« Right Overhang — overhang length on the right side of the bent cap, measured from the exterior face
of the leading column

Units: in, Default: 24.0
The user input values for the bent cap depth and width are used to determine the axial and flexural stiffness
of the cap beam elements in the finite element model while the left and right overhang lengths are used tc

compute axial, shear, and moment forces in the cap beam elements. In addition, the bent cap depth is usec
to determine the location where the bent displacement is reported for transverse and longitudinal analyses.
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2 Bent Cap

File Help |

Depth (48.0 in

Width |72.0 in

Left Overhang 24.0 in
Right Overhang 24.0 in

oK | Cancel |

Figure 2.6: Userinterface for bent cap dimensions.

2.5 Column/Pile Loads

Although the cross-section details are the same for each column and pile, the gravity load and p-multipliers
can be different for each column/pile. The gravity load applied to each column and the p-multipliers applied
to each pile can be accessed and edited through one of the following methods:

« Double-click on a gravity load arrow in the main window (Figure 1.3); or

e Select Edit -> Column/Pile Loads -> Column/Pile X from the main menu, where X is the col-
umn/pile number.

After using one of these two methods, the user interface shown in Figure 2.7 appears and the following load
values can be modified:
e Gravity Load — gravity, or dead, load applied to the selected column
Units: kip, Default: 984.4 (10% of gross column capacity)
* p-Multiplier Transverse — p-multiplier applied to the selected pile for loading of the bridge bent in
the transverse direction
Default: 1.0
e p-Multiplier Longitudinal — p-multiplier applied to the selected pile for loading of the bridge bent
in the longitudinal direction
Default: 1.0
e Apply to all — checkbox to apply the gravity load and p-multipliers for the selected column/pile to
all columns/piles

Default: False
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x Column/Pile Loads

File Help |
Column/Pile 1
Gravity Load m kip
p-Multiplier Transverse|1.0

p-Multiplier Longitudinal |1-D
[ Apply to all

oK | Cancel |

Figure 2.7: User interface for column gravity load and pile p-multipliers.

2.6 Soil Properties

The software uses soil-structure interaction in all analyses based on the properties of multiple soil layers

below grade as well as the depth to the water table.

2.6.1 Water Table

The depth to the water table can be accessed and edited through one of the following methods:

< Double-click on the Water Table, XX ft text (above the blue line) in the main window (Figure 1.3);

or
* Select Edit -> Soil -> Water Table from the main menu.

After using one of these two methods, the user interface shown in Figure 2.8 appears and the depth to the

water table can be modified. The units are ft and the default value is 3.0 ft.

% Water Table

File Help |
Depth to Water Table

|3_D ft

oK | Cancel |

Figure 2.8: Userinterface for depth to water table.
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2.6.2 Soil Layers

The subgrade region of the bridge bent model can be characterized by multiple layers of three types of sail:
sand, normally consolidated (soft) clay, and over consolidated (stiff ) clay. In addition to basic properties fol
these three types of soil, a p-multiplier can be set for each layer, e.g., to represent a liquefied or frozen soi
layer. The properties of each soil layer can be accessed and modified through one of the following methods:

« Double-click anywhere in a soil layer in the main window (Figure 1.3); or
e Select Edit -> Soil -> Layer X from the main menu, where X is the soil layer number.

After using one of these two methods, the user interface shown in Figure 2.9a appears. Note that Sand is
the default soil layer type. Regardless of the type of soil, the following properties can be modified for all soi
layers:

Depth — depth of the selected soil layer
Units: ft, Default: 20.0

e Multiplier— p-multiplier for the selected soil layer

Default: 1.0

e p-y Spacing — vertical spacing of the p-y springs in the finite element model
Units: ft, Default: 1.0
Note: This field is disabled for editing
« Apply to all soil layers — checkbox to apply the soil properties and p-multipliers for the selected
soil layer to all soil layers
Default: False

Additional input fields are enabled/disabled based on the type of soil layer, either Sand, N.C. Clay, or O.C.
Clay, as shown in Figures 2.9a—2.9c.

e gamma — unit weight of soll

phi —angle of internal friction

¢ — soil shear strength

eps50 — soil strain corresponding to 50% of the maximum principal stress difference
e nh —increase in soil stiffness with respect to depth

The applicability and default values and units of these properties to each type of soil is summarized ir
Table 2.1. There is also a button, P-Y Curves, to generate and view force-deformation curves for each p-y
spring in the selected soil layer. This information is also echoed in the report generated by the software, as
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8 Soil Properties e Soil Properties g2 Soil Properties

File Help File Help \ File Help \
Soil Layer 1 Soil Layer 1 Soil Layer 1
Depth [20.0 ft Depth 20.0 ft Depth 200 ft
Multiplier (1.0 Multiplier 1.0 Multiplier (1.0

p-y Spacing ft p-y Spacing ft p-y Spacing | ft
Type Sand — Type N.C. Clay — Type O.C. Clay —

:

gamma |(125.0 pcf gamma |125.D pcf gamma |125.D pcf
phi 28.0 deg phi | deg phi | deg

C psi c |2.5 psi C |2.5 psi
eps50 infin eps50 |D.D2 in/in eps50 |D.D2 in/fin

nh 50.0 pci nh | pci nh |5D.D pci
[ Apply to all soil layers [ Apply to all soil layers [ Apply to all soil layers
P-Y Curves | P-Y Curves | P-Y Curves |
oK | Cancel | 0K | Cancel | oK | Cancel |
(a) Sand (Default). (b) Normally consolidated clay. (c) Over consolidated clay.

Figure 2.9: Userinterface for properties and p-multiplier of a soil layer.

described in Chapter 4, and will not be described here. The implementation of each of p-y soil model follows

the procedures described in [12], with formulations developed by [10], [5], and [9] for O.C. clay, N.C. clay,
and sand, respectively.

Table 2.1: Applicability of soil propertiesto sand, N.C. clay, and O.C. clay.

Property Units Default | Sand N.C. Clay O.C. Clay
gamma  pcf 125.0 X X X
phi deg 28.0 X
c psi 25 X X
eps50  infin 0.02 X X
nh pci 50.0 X X

2.7 Saving the Bridge Model

The current properties of the bridge bent model can be saved to file by via one of the following approach:

e Type Ctrl + S in the main window (Figure 1.3)
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» Select File -> Save from the main menu

This will bring the dialog shown in Figure 2.10. The file extension for files saved by the software is .cis and

the default file name for the bridge model is the bridge name.

Directory:  /home/mhscott/Dropbox/Apps/ShareLaTeX/AKDOT CISS 2.0 _.| |

7 versionl.0
E] Butler.cis

Save

Files of type: CISS Analysis Files (*.cis,*.CIS) — Cancel

Figure 2.10: Dialog to save a bridge bent modelto file.

2.8 Loading a Bridge Model

A previously analyzed bridge bent model can be opened from file by via one of the following approach:

e Type Ctrl + 0 in the main window (Figure 1.3)
« Select File -> Open from the main menu

This will bring the dialog shown in Figure 2.11, which will filter files with the .cis extension.
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Directory:  /home/mhscott/Dropbox/Apps/ShareLaTeX/AKDOT CISS 2.0 _.| |

(7 versionl.0

E] Butler.cis

Kl ¥
File name: | Open

Files of type: CISS Analysis Files (*.cis,*.CIS) — Cancel

Figure 2.11: Dialog to load a bridge bent model from file.
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Chapter 3

Finite Element Analysis

Using the bridge bent inputs for structural and soil properties described in Chapter 2, the software creates
a two-dimensional (2D) nonlinear finite element model from modules available in OpenSees [6]. The model

consists of frame (beam-column) and spring elements as described herein.

3.1 Boundary Conditions

The element connectivity and boundary conditions of the bridge bent model are shown in Figure 3.1. The
same model is used for transverse and longitudinal analyses with only one difference in the bent cap model
For the transverse model, vertical bent cap elements extend from the top of the column to the mid-depth o
the bent cap (dcap /2) with horizontal elastic frame elements connecting each column line, allowing for frame
action. For the longitudinal model, the vertical bent cap elements extend over the entire bent cap depth
deap, With horizontal elastic truss elements (moment releases at each end) connecting each column line. This
removes frame action for the longitudinal analyses. Although longitudinal analyses can be accomplishec
with only one line of column/pile elements and no horizontal bent cap elements, this approach reduces
programming complexity as essentially the same model is used for transverse and longitudinal analyses. The
additional computational expense encumbered by this approach is minimal as this is a 2D finite element
model with a relatively small number of nodes and elements.

At the base of each pile extension, a roller support prevents vertical displacement but allows rotatior
and horizontal displacement. The soil p-y springs provide the reaction forces that prevent rigid body dis-
placement. If soil-structure interaction (SSI) effects are disabled in the analysis, the ground level nodes a
the base of each column are completely fixed and will develop reaction forces. If SSI is disabled, the pile and

p-y spring elements are not generated.
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Figure 3.1: Finite element idealization of bridge bent system for transverse and longitudinal analyses.
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3.2 Finite Element Formulations

The finite element formulations utilized in the 2D model shown in Figure 3.1 are as follows, along with the
associated OpenSees element commands:

e Bent Cap - linear-elastic, small displacement elastic beam-column elements utilizing the Euler-
Bernoulli beam theory

element forceBeamColumn with section Elastic at two Gauss-Legendre integration points and geom-
Transf Linear geometric transformation; for a longitudinal analysis, element truss is used for the
horizontal elements in the bent cap region

e Columns Above Grade — material nonlinear, large displacement beam-column elements utilizing
the Euler-Bernoulli beam theory

element forceBeamColumn [7] with the HingeRadau integration rule [11] with fiber-discretized sectior
Fiber cross-sections and geomTransf Corotational geometric transformation [2] (gegomTransf Linear i
the user does not select P -A effects); the gap section is used for the integration point at the top of the
column while the steel shell section is used at all other integration points along the column height; the
plastic hinge length at the top of the column is equal to that input by the user (see section 2.3)

e Piles Below Grade — material nonlinear, small displacement beam-column elements utilizing the
Euler-Bernoulli beam theory

element dispBeamColumn with fiber-discretized section Fiber cross-sections at two Gauss-Legendre
integration points and geomTransf Linear geometric transformation; the steel shell column cross-sectior
is used for pile elements above the column/pile transition depth while the pile cross-section is usec
below this depth

« Soil Springs Below Grade — zero length p-y spring elements with one-dimensional (uniaxial) force-
deformation response

element zeroLength with uniaxialMaterial response based on which of the three soil types the user
selected for each layer; allowances for the buoyant weight of soil below the water table are also made
if the user has selected this option

3.3 Analysis Options

The software offers the user control over some of the aforementioned analysis options through two interfaces.

3.3.1 Modeling Options

The first interface allows the user to control modeling options that apply to all analyses executed by the
software. The interface is shown in Figure 3.2 and it can be accessed in the following manner

30



e Select Edit -> Analysis Options -> Modeling Options from the main menu

o

Modeling Options

File Help |
Owverstrength Factor 1.0

Soil-5tructure Interaction «~ On  Off

P-Delta Analysis & On  Off

Soil Buoyant Weight below GWT & On  Off

Draw Displaced Shape « On & Off

Draw Moment Diagram ~ On  Off

Draw Shear Diagram " On & Off

oK | Cancel |

Figure 3.2: Modeling options for bridge bent analyses.

After accessing the modeling options window of Figure 3.2, the following options can be accessed and edited:

Overstrength Factor — factor applied to the strength of steel (fy) and concrete (fY) material prop-
erties in the bridge bent model

Default: 1.0

Soil-Structure Interaction — binary field to enable/disable soil-structure interaction in analyses

Default: On

P-Delta Analysis — binary field to enable/disable column P-A effects in the analyses

Default: On

Soil Buoyant Weight below GWT — binary field to enable/disable the use of buoyant weight for soll
below the ground water table (GWT)

Default: On
The interface shown in Figure 3.2 has three additional binary fields to draw the displaced shape of the bridge
bent and the moment and shear diagrams of the column/pile elements during analyses. By default, only the

moment diagram is drawn. Note that more than one of these diagrams can be selected for drawing during
analyses and that each diagram is shown individually in the generated report, as described in Chapter 4.
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3.3.2 Pushover Analysis Options

The second interface allows the user to control basic parameters for pushover analyses. The interface is
shown in Figure 3.3 and it can be accessed in the following manner

e Select Edit -> Analysis Options -> Pushover Analysis from the main menu

D Pushover Analysis Options

File Help |

Max Displacement Transverse 2.0 ft
Max Displacement Longitudinal 3.0 ft
Post Peak Capacity 80 %

oK | Cancel |

Figure 3.3: Pushover analysis options for bridge bent analyses.

After accessing the pushover analysis options window of Figure 3.3, the following options can be accessed
and edited:

e Max Displacement Transverse — the maximum displacement at which the pushover analysis in the
transverse direction will terminate
Units: ft, Default: 3.0

Max Displacement Longitudinal —the maximum displacement at which the pushover analysis in the
longitudinal direction will terminate

Units: ft, Default: 2.0

« Post Peak Capacity — the percentage of peak capacity at which pushover analyses will terminate
after reaching the peak capacity and losing lateral load resistance

Default: 80%

Note: The interpretation of this option is shown in Figure 3.4.

3.4 Limit States

The software allows for user-defined limit states that are denoted in the load-displacement response for each
pushover analysis. The limit states correspond to strain limits on the steel and concrete of the columns/piles.
To access and edit the limit states:
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Figure 3.4: Interpretation of post-peak capacity as percentage of peak capacity in a pushover analysis.

* Select Edit -> Limit States from the main menu

After accessing the limit states interface, the window shown in Figure 3.5 will appear and the following limit
states will be available for updating:

e Reinforcing Steel — strain limit in the longitudinal reinforcing steel in the columns/piles

Units: in/in, Default: 0.06

e Jacket Steel —strain limit in the steel shell of the columns/piles

Units: in/in, Default: 0.026

« Concrete — strain limit in the concrete of the columns/piles

Units: in/in, Default: 0.02
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Strain Limit States

File Help
Reinforcing Steel 0.06  infin
Steel Shell 0.026 infin
Concrete 0.02  in/fin

oK | Cancel |

Figure 3.5: Strain limit states for bridge bent analyses.
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Chapter 4

Summary Report

The software creates a PDF report that summarizes the geometric and material properties of the bent, as
well as analysis results. The dialog to create a report shown in Figure 4.1 is accessed by pressing the Create

Report button of the main window. The default report file extension in .pdf and the file name is the bridge
name.

x Create Report

Directory:  /home/mhscott/Dropbox/Apps/ShareLaTeX/AKDOT CISS 2.0 _.| |

7 versionl.0

El FEModel pspdftex.pdf

El Horizontal-cmyk 1.pdf

E mhs.pdf

El PeakCapacity pspdftex.pdf

File name: [=§

Save

Files of type: Acrobat (*.pdf,*.PDF) — Cancel

Figure 4.1: Dialog to create a summary report for the bridge bent model.

The remainder of this chapter shows sample report output using the default bridge bent properties and
analysis options.
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The title page echoes information from the main window including the bridge name, engineer name, and
date of analysis and displays a table of contents.

Bridge1483296408456420

Bridge Analysis Summary

John Doe, P.E.
01/01/2017 10:46:52

Alaska DOT&PF Pile Extension Pier Pushover Program, v2.0

Contents
Bent Overview 2
Transverse Pushover Analysis 3
Longitudinal Pushover Analysis 7
CISS/Pile Section Details 11
Gap Section Moment-Curvature 12
Section Axial-Moment Interaction 13
Longitudinal Reinforcing Steel 14
Jacket Steel 15
Concrete 16
Soil Layers 17

Figure 4.2: Report title page and table of contents.

36



The bent overview page shows the structural dimensions of the bridge bent and soil layers as well as the
shell gap and plastic hinge length. The bridge model is rendered in black and white for better printing.

Bridge1483296408456420
John Doe, P.E.
Bent Overview
Column Height 14.0 ft above grade
Cap Beam depth 48.0in
Cap Beam width 72.0 in
Shell Gap, Gf 2.0in
Plastic Hinge Length, Ip 2.50 ft
Water Table 3.0 ft below grade
Total Soil Depth 60.0 ft below grade
984.4 984.4 984.4
kip kip kip
Gf=2.00in
8.0 fto.c. 8.0 fto.c.
Column L Column p Column B
Waler Tablg, 3.00 11
Sand
Layer 1 20.00 ft p=1.0
File 1 Rile 2 Rile 3
=1.0 (T) =1.0(T) Sand P=1.0 (T)
Layer §=1.0 éL 20.00ft 4-170 ?L p=1.0 p=1.0 éL
4 Sand
Layer 3 20.00 ft p=1.0
2

Figure 4.3: Bent overview produced for the summary report.
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The transverse pushover load-displacement response is included in the report, along with information on the
analysis options and any limit statesthat are reached during the analysis. Note that the displacement is
reported at the center of the bent cap for the transverse pushover analysis.

Bridge1483296408456420
John Doe, P.E.
Transverse Pushover Analysis
Max Displacement 2.0 ft
P-Delta Analysis On
Soil-Structure Interaction On
Soil Buoyant Weight below GWT On
Overstrength Factor 1.0
R/F Steel Yield 0.21 ft, 426.6 kip
R/F Steel Strain Limit (0.06 in/in) N/A
Jacket Steel Strain Limit (0.026 in/in) N/A
Concrete Strain Limit (0.02 in/in) 2.00 ft, 1008.0 kip
Peak Capacity 2.00 ft, 1008.0 kip
Post Peak Limit (80% Peak) N/A
Load (kip)
1200.0 T T T T
1000.0 - Concrete Limit 1
800.0 + b
600.0 | 4
400.0}+ First Steel Yield |
200.0} 4
0 . . . .
0 0.5 L0 picokeBment @y 2-0 25 3.0
3

Figure 4.4: Transverse pushover results included in the summary report.
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The displaced shape of the bridge bent at the end of the transverse pushover analysis is included in the report
along with the extreme axial loads in each column and the extreme forces in the bent cap beam members.

Bridge1483296408456420
John Doe, P.E.

Final Transverse Displaced Shape

Extreme Axial Loads Column 1: 358.7 kip (C) to 984.4 kip (C)
Column 2: 881.8 kip (C) to 984.4 kip (C)

Column 3: 984.4 kip (C) to 1644.2 kip (C)

Bent Cap Forces Inside trailing pile: N=-1.9 kip, V=-604.1 kip, M=3106.3 kip-ft
Inside leading pile: N=-0.7 kip, V=-684.0 kip, M=3773.8 kip-ft

984.4 984.4 984.4
kip kip kip

f=2.00in
8.0fto.c. 8.0fto.c.
Column Column Column
rrable, 3.00 fi
Sand
Layer 1 20.00 ft p=1.0
Piled Pile Sand Pile
Layer2 | pP=1P (M 20.00 ft p=13§ (T) oo p=1P (T)
p=1H3R)5 ft p=1§-ej5ft Pl p=1}30)5 ft
Sand
Layer 3 20.00 ft p=1.0
-56.9 ft 56.9 ft -56.9 ft

Figure 4.5: Transverse displaced shape included in the summary report.
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The bending moment distribution through the columns/piles of the bridge bent at the end of the transverse

pushover analysis is included in the report.

Bridge1483296408456420
John Doe, P.E.

Final Transverse Moment Diagram

984.4 984.4 984.4
kip kip kip

2438.2 kip-ft 2750.7 kip-ft 3100.4 kipl—ﬂ
T&t=2.000n 270 ft T40 ft
8.0fto.c. 8.0fto.c.
2 fl 7.0 ff 7.0 f
Colilin 1 Co/nn 2 (:o/lémn 3
| | | ater[Table, 3.00 f
| | |
II | II
Sand
Layer 1 20.00 ft f’ p=1.0
7017.8 kip-ft 72598 kipift 75553 kip|ft
-19.9 ft -19.4 ft -19.5 ft
*ne i ’.ne P sand "ile B
Layer 2 =110 (T) 20.00 ft =1.D (T) =100 (T)
Y pELD (L) pELD (L) p=1.0 pELD (L)
| | |
I I I
I I I
I I
-47.4 ft -47.9 ft g 4841t
Layer 3 20.00 ft p=1.0

Figure 4.6: Transverse moment diagram included in the summary report.
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The shear force distribution through the columns/piles of the bridge bent at the end of the transverse

pushover analysis is included in the report.

Bridge1483296408456420
John Doe, P.E.

Final Transverse Shear Diagram

984.4 984.4 984.4
kip kip kip

334.1 kip 336.7 lkip
[GA-0F00 in 14.0ft
8.0fto.c. 8.0fto.c.
Column 1 Column 2 Column 3
337.2 Kip
| ater[fable, 3.00 f
|I Sand
Layer 1 | 20.00 ft | p=1.0 |

‘N‘ Pile L m If Pile p o sand 1 "
Layer 2 > 20.00 ft 5 3 ki
avet i‘} Egh (L) fzﬁﬁ?ﬁ L) p=1.0 fé‘%}? O]

Layer 3 20.00 ft p=1.0

Figure 4.7: Transverse shear diagram included in the summary report.
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The longitudinal pushover load-displacement response is included in the report, along with analysis options
and any limit states that are reached during the analysis. Note that the displacement is reported at the top
of the bent cap for the longitudinal pushover analysis.

Bridge1483296408456420
John Doe, P.E.
Longitudinal Pushover Analysis
Max Lateral Disp 3.0 ft
P-Delta Analysis On
Soil-Structure Interaction On
Soil Buoyant Weight below GWT On
Overstrength Factor 1.0
R/F Steel Yield N/A
R/F Steel Strain Limit (0.06 in/in) N/A
Jacket Steel Strain Limit (0.026 in/in) N/A
Concrete Strain Limit (0.02 in/in) N/A
Peak Capacity 2.88 ft, 670.6 kip
Post Peak Limit (80% Peak) N/A
Load (kip)
700.0 T T T
[Peak Capacity
600.0+ 8
500.0+ g
400.0+ 8
300.0+ g
200.0+ 8
100.0+ 8
0 . . .
0 1.0 Displgcgment (ft) 3.0 4.0
7

Figure 4.8: Transverse shear diagram included in the summary report.
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The displaced shape of the bridge bent at the end of the longitudinal pushover analysis is included in the

report along with the extreme axial loads in each column and the extreme forcesin the bent cap beam
members.

Bridge1483296408456420
John Doe, P.E.

Final Longitudinal Displaced Shape

984.4 984.4 984.4
kip kip kip

Gf£2.00in
8.0fto.c. 8.0fto.c.
Column 1 Column 2 Column 3
5‘ 5‘ Table, 3.00
Sand
Layer 1 ? 20.00 ft i p=1.0
Pileg Pileg Sand Pile
Layer2 | p=1p30)Hft 20,00t p=1930)g ft sy p=1P30)g ft
p=10 (L) p=1d (L) p=1. p=1d (L)
Sand
Layer 3 20.00 ft p=1.0
55.5 ft 55.9 ft 55.9 ft

Figure 4.9: Longitudinal displaced shape included in the summary report.
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The bending moment distribution through the columns/piles of the bridge bent at the end of the longitudinal

pushover analysis is included in the report.

Bridge1483296408456420
John Doe, P.E.

Final Longitudinal Moment Diagram

984.4 984.4 984.4
kip kip kip

Gf=2.00in
8.0fto.c. 8.0fto.c.
mn 1. n2 n3
|I J J aterFable, 3.00 f
|. + +
Sand
Layer 1 20.00 ft p=1.0
17687|6 kip{ ft 17687|6 kipift 17687|6 kipift
-16.5(ft 16.5/ft -16.5 ft

ile L hile P sand ile B
Layer 2 =110 (T) 20.00 ft F1.D (T) an =1.0 (T)
pk1p (L) pk1p (L) p=1.0 pk1.p (L)
I I I
I I I
Layer 3 176.8 kip-f0.00 ft 176.8 kip-ftSand 176.9 kip-ft
-50. ft 508 ft P=10 50,9 ft

Figure 4.10: Longitudinal moment diagram included in the summary report.
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The shear force distribution through the columns/piles of the bridge bent at the end of the longitudinal

pushover analysis is included in the report.

Bridge1483296408456420
John Doe, P.E.

Final Longitudinal Shear Diagram

984.4 984.4 984.4
kip kip kip

Gf=2.00in
8.0fto.c. 8.0fto.c.
Column Column Column
23.5 kip 23.5 kip £23.5 Kip
| | ate] e, 3.00 f
Sand
Layer 1 | 20.00 ft I| iy {

Layerz{%%%h)m 20.00 ft 14‘ :

Layer 3 W 20.00 ft p=1.0

10

Figure 4.11: Longitudinal shear diagram included in the summary report.
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Cross-section details of the column/pile cross-section are included in the report. Note that if the column

and pile cross-sections are different, the report will include an additional page showing the pile cross-section
details.

Bridge1483296408456420
John Doe, P.E.

CISS/Pile Section Details

Outer Shell Diamter, Dj 36.00 in
Shell Thickness, tj 0.75 in
Clear Cover 2.00 in
Number of Bars 16
Bar Size 11
Long. R/F Ratio 0.02670
Spiral Size 5
Hoop Spacing 3.00 in
Yield Stress 60.00 ksi

11

Figure 4.12: Column cross-section details included in the summary report.
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The moment-curvature response of the gap section at the top of the column is included in the report. Two
analyses are shown for the two extreme axial loads recorded during the transverse pushover analysis.

Bridge1483296408456420
John Doe, P.E.

Gap Section Moment-Curvature

Core Confinement Spiral Hoop
Cover Confinement Same as Core
Target Ductility 25.0
Extreme Axial Loads 960.2 kip (C) in Column 1 @ 670.4 kip

984.4 kip (C) in Column 1 @ 0.0 kip

Moment (kip-ft)
3000.0 T T T T

2500.0

2000.0

1500.0

1000.0

500.0 1

0 0.01 0.02 vature 3 0.04 0.05
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Figure 4.13: Gap section moment-curvature included in the summary report.
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The axial-moment interaction curves for the gap cross-section and the column/pile cross-section are included
in the report. Note that if the column and pile cross-sections are different, an additional interaction curve
will be drawn for the pile cross-section. The termination criteria for each point on the interaction curves is
that the cross-section reaches its yield curvature.

Bridge1483296408456420
John Dog, P.E.

Section Axial-Moment Interaction

Gap Region
Core Confinement Spiral Hoop
Cover Confinement Same as Core

CISS/Pile Section
Balance Point @ N = 3445.5 kip 6579.2 kip-ft

Gap Section
Balance Point @ N = 3445.5 kip 2471.3 kip-ft

N (kip)
20000.0

CISS/Pile Settion T T T

14000.0+

Gap Section

8000.0F

(2471.3,3445.5) (6579.2,3445.5)

2000.0F

-4000.0+ 1

-10000.0 - - - -
0 1400.0 2800.0,, (kipz_;goo.o 5600.0 7000.0
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Figure 4.14: Section axial-moment interaction curves included in the summary report.
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The stress-strain response curves of the longitudinal reinforcing steel and the steel shell are included in the
report along with the material properties.

Bridge1483296408456420 Bridge1483296408456420
John Doe, P.E. John Doe, P.E.
Longitudinal Reinforcing Steel Jacket Steel
Elastic Modulus, E 29000.0 ksi Elastic Modulus, E 29000.0 ksi
Yield Stress, fye 68.0 ksi Yield Stress, fye 60.0 ksi
Ultimate Stress, fue 95.0 ksi Ultimate Stress, fue 78.0 ksi
Strain-Hardening Onset, epssh 0.0115 infin Strain-Hardening Onset, epssh 0.0115 infin
Strain-Hardening Coefficient, C1 15 Strain-Hardening Coefficient, C1 15
Rupture Strain, epssuR 0.06 infin Rupture Strain, epssuR 0.04 infin
Ultimate Strain, epssu 0.09 infin Ultimate Strain, epssu 0.06 in/in
Stress (ksi) Stress (ksi)
100.0 ‘ ‘ . . 80.0
80.0}
60.0} ,
60.0|
40.0 E
40.0
20.0 ,
20.0
%5 0.02 0.0% 3,3 06 0.08 0.1 0 ] ‘ ] ]
. " Strain (in . .
( 0 0.02 0.04 gy (P6 0.08 0.1
14 15
(a) Reinforcing steel. (b) Steel shell.

Figure 4.15: Steel stress-strain response included in the summary report.
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The stress-strain response of the concrete in the columns/pilesis included in the report. Stress-strain curves
are shown for unconfined concrete, as well as the confined concrete of the gap region and the confined
concrete of the steel shell cross-section.

Bridge1483296408456420

John Doe, P.E.
Concrete
Expected Concrete Strength, f'ce 5.20 ksi
Cracking Strain, eco 0.0020 in/in
Tangent Modulus, Ec 5200.00 ksi
Spalling Strain, esp 0.0060 in/in
Steel Shell (CISS) Spiral Hoop
Compressive Strength, f'cc 14.43 ksi 7.60 ksi
Peak Strain, ecc 0.01974 in/in 0.00661 in/in
Secant Modulus, Esec 730.71 ksi 1149.37 ksi
Mander Coefficient, r 1.16 1.28

Stress (ksi)
15.0 T T T

10.0

5.0

0 0.01 0%y 0.03 0.04
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Figure 4.16: Concrete stress-strain response included in the summary report.
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The load-deformation response of each p-y spring in the first soil layer is included in the report. The report

includes additional pages for the remaining soil layers.

Bridge1483296408456420
John Doe, P.E.
Soil Layer 1: Sand
Depth range 0.0 - 20.0 ft
p-Multiplier 1.0
Unit weight, gamma 125.0 pcf
Angle of internal friction, phi 28.0 deg
Stiffness increase wrt depth, nh 50.0 pci
p-y spring spacing 10 ft
Number of p-y springs 20
p (kip/ft)
50.0 T T T T
=195 ft
40.0+ B
=185 ft
=175 ft
30.0} =16.5 ft ]
=155 ft
=145 ft
=135 ft
20.0+ B
=125ft
=105 ft
=951t
=83ht
10.0 = 6.5 ft 4
= iAS ft
=45ft
=351t
=151t
=05 ft
0 . . .
0 0.2 0.4 0.6 0.8 1.0
y (ft)
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Figure 4.17: Soil load-deformation (p-y) response included in the summary report.
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